httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: [patch] have_min_apache_version: 2.0.48-dev is not 2.0.48
Date Mon, 22 Sep 2003 17:12:19 GMT


Stas Bekman wrote:
> Since  2.0.48-dev is not 2.0.48 I believe we should look at it as 2.0.47 
> in the tests? or should we not complicate things and have those who use 
> -dev always keep up with the latest versions? I'm not sure if this 
> should go in.

if 2.0.48-dev reports as 2.0.48 then I think that is the proper behavior.

as with any change in version, it's the different features that make it 
interesting, not the same ones.  so reporting 2.0.47 for 2.0.48-dev would be 
counter productive - if you're a developer and working on a test that 
excercises a new feature in the -dev version, you want it to run the new 
tests on 2.0.48 but not 2.0.47.  downgrading the -dev version would make it 
impossible to insert have_min_apache_version() logic in the tests prior to 
release, and remove what is otherwise a nice migratory path.

was this just a thought, or is there a situation you are running into that 
prompted your suggestion?  if the latter, maybe we can work on some other 
API that suited your needs?  as I've been writing tests against development 
features for a while now, I'm quite happy with the current behavior :)

--Goeff


Mime
View raw message