httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: resolving Apache::Test vs. Apache::test collision
Date Thu, 08 May 2003 13:34:01 GMT
On Thu, 8 May 2003, Stas Bekman wrote:
 
> The problem with providing a replacement for Apache::test is
> that some people are going to reinstall older mod_perl versions
> and kill the overriden file.

That's certainly true in general (for case-preserving but
otherwise case-insensitive file systems) - I just thought I'd
clarify why this problem never really arose before on ActivePerl
Win32. There, mod_perl 1 works with perl-5.6.1 but not with
perl-5.8.0 (due to large files support), and mod_perl 2 works
with perl-5.8.0, but not (practically speaking) with perl-5.6.1.
So it's very rare that Apache::test and Apache::Test would get
installed within the same Perl tree, at least while these two
were tied to particular mod_perl versions.

-- 
best regards,
randy


Mime
View raw message