httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: resolving Apache::Test vs. Apache::test collision
Date Fri, 09 May 2003 00:39:10 GMT
Randy Kobes wrote:
> On Thu, 8 May 2003, Stas Bekman wrote:
>  
> 
>>The problem with providing a replacement for Apache::test is
>>that some people are going to reinstall older mod_perl versions
>>and kill the overriden file.
> 
> 
> That's certainly true in general (for case-preserving but
> otherwise case-insensitive file systems) - I just thought I'd
> clarify why this problem never really arose before on ActivePerl
> Win32. There, mod_perl 1 works with perl-5.6.1 but not with
> perl-5.8.0 (due to large files support), and mod_perl 2 works
> with perl-5.8.0, but not (practically speaking) with perl-5.6.1.
> So it's very rare that Apache::test and Apache::Test would get
> installed within the same Perl tree, at least while these two
> were tied to particular mod_perl versions.

Cool. What about MacOSX? Any other systems?

The other issue is that we have to ship and install Test.pm and test.pm, 
because mp1 users will need test.pm on case-sensitive systems. On case 
insensitive systems only one of these will be installed (the other will 
overwrite the first one).

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message