httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Bannert <aa...@clove.org>
Subject 2.0.28 results, need interpretation
Date Tue, 13 Nov 2001 18:20:58 GMT
I'm fairly new to the perl-framework testing harness, and I'm getting
some results I'm not sure how to interpret on my Solaris 8 build of
the rolled 2.0.28 tarball.

With the worker MPM (with --enable-cgid) I get:

Failed Test     Status Wstat Total Fail  Failed  List of Failed
--------------------------------------------------------------------------------apache/limits.t
              10    1  10.00%  9
modules/cgi.t                 36   33  91.67%  1-4, 6, 8-27, 29-36

But on prefork with the same build parameters (s/cgid/cgi of course) I get
only:

Failed Test     Status Wstat Total Fail  Failed  List of Failed
--------------------------------------------------------------------------------apache/limits.t
              10    1  10.00%  9


The limits failure has to with LimitRequestBody, and looks to be a known
issue (see modules/http/http_protocol.c:1314, "/* XXX shouldn't we enforce
this for chunked encoding too? */"). But you probably already knew this. :)

As for the cgi error, is this the error that Cliff reported earlier? It
looks like it's a simple error with how @CGI_MODULE@ is being replaced
in t/conf/extra.conf.in on about line 175. In my setup, no matter what
I do it gets replaced with mod_cgi.c, which means those directives are
never included with worker's mod_cgid.c. Can someone with more experience
with perl voodoo check this out and let me know what I'm doing wrong here?

-aaron

p.s. Solaris 8 intel (07/'01 update), perl 5.6.1

Mime
View raw message