httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Benson <gben...@redhat.com>
Subject Re: How to make the c-modules run?
Date Tue, 28 Aug 2001 14:22:25 GMT

On Tue, 28 Aug 2001, Stas Bekman wrote:

> On Tue, 28 Aug 2001, Gary Benson wrote:
>
> > On Tue, 28 Aug 2001, Stas Bekman wrote:
> >
> > > On Tue, 28 Aug 2001, Gary Benson wrote:
> > >
> > > > Hi,
> > > >
> > > > When I run the perl test script a number of tests are skipped. I think
> > > > this is something to do with the fact that the stuff in c-modules never
> > > > gets built -- my c-modules/Makefile looks like this:
> > > >
> > > > | MAKE = make
> > > > | clean:
> > > > |
> > > > | all:
> > > > |
> > > >
> > > > Should I be doing something special to make the c-modules get built?
> > > > The only notable error I ever see is that "apxs -q BINDIR" fails twice
> > > > whilst configuring the server. I don't know if this is an Apache 2.x thing
> > > > since I'm using 1.3.20, but if it is could someone please advise me as
to
> > > > where it should point.
> > >
> > > Try the latest cvs, rbb has committed my patch a few hours ago.
> > >
> > > e.g. it works now:
> > >
> > > % /home/stas/httpd-2.0/bin/apxs -q BINDIR
> > > /home/stas/httpd-2.0/bin
> >
> > But this is for 2.0; what is the 1.3 equivalent of the BINDIR? SBINDIR?
>
> Mine is built statically so I cannot test, but from looking at apxs in
> 1.3, yes, it's SBINDIR.

Okay, thanks.

I can see I'm going to have to checkout a copy of 2.0, if only to check
the breaking tests against it ;-)

BTW, is anyone on this list trying to use httpd-test on 1.3, or am I on my
own here?

Gary

[ Gary Benson, Red Hat Europe ][ gbenson@redhat.com ][ GnuPG 60E8793A ]


Mime
View raw message