httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Benson <gben...@redhat.com>
Subject Re: He answers his own question [was Failing mod_env tests]
Date Tue, 28 Aug 2001 13:51:14 GMT

On Tue, 28 Aug 2001, Ryan Bloom wrote:

> On Tuesday 28 August 2001 06:21, Gary Benson wrote:
> > On Tue, 28 Aug 2001, Gary Benson wrote:
> > > I'm getting failures on a couple of the mod_env tests, specifically 2 and
> > > 4, both tests which test UnsetEnv. Has anyone else had this?
> >
> > Ah, I see that Doug fixed a bug here in httpd-2.0. Is there any chance of
> > this fix appearing in 1.3.x?
>
> It is incredibly unlikely.
>
> Ryan

In case you want it, here's my patch to disable the failing tests under
Apache 1.x. I'm not sure if it should be comitted or not -- is it The
Right Thing to disable tests that don't work in some versions? I don't
know, at any rate.

Gary

Index: t/modules/env.t
===================================================================
RCS file: /home/cvspublic/httpd-test/perl-framework/t/modules/env.t,v
retrieving revision 1.3
diff -u -r1.3 env.t
--- t/modules/env.t	2001/08/24 01:17:45	1.3
+++ t/modules/env.t	2001/08/28 13:40:05
@@ -3,6 +3,7 @@

 use Apache::Test;
 use Apache::TestRequest;
+use Apache::TestConfig;

 ##
 ## mod_env tests
@@ -15,6 +16,12 @@
     'type' => '(none)',
     'nothere' => '(none)'
 );
+
+my $env = Apache::TestConfig->thaw;
+if( $env->{server}->{rev} == 1 ) {
+    delete $test{type};
+    delete $test{nothere};
+}

 plan tests => (keys %test) * 1, test_module('env', 'include');



Mime
View raw message