httpd-test-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject svn commit: r124143 - /httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm
Date Tue, 04 Jan 2005 19:23:57 GMT
Author: stas
Date: Tue Jan  4 11:23:51 2005
New Revision: 124143

URL: http://svn.apache.org/viewcvs?view=rev&rev=124143
Log:
simplify the code

Modified:
   httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm

Modified: httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm
Url: http://svn.apache.org/viewcvs/httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm?view=diff&rev=124143&p1=httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm&r1=124142&p2=httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm&r2=124143
==============================================================================
--- httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm	(original)
+++ httpd/test/trunk/perl-framework/Apache-Test/lib/Apache/TestRunPerl.pm	Tue Jan  4 11:23:51
2005
@@ -51,15 +51,16 @@
     } else {
         eval { require mod_perl };
     }
+
+    my $mp_ver = $mod_perl::VERSION;
     if ($@) {
         error "You are using mod_perl response handlers ",
             "but do not have a mod_perl capable Apache.";
         Apache::TestRun::exit_perl(0);
     }
-    if (($rev == 1 and $mod_perl::VERSION >= 1.99) ||
-        ($rev == 2 and $mod_perl::VERSION < 1.99)) {
-        error "Found mod_perl/$mod_perl::VERSION, " .
-            "but it can't be used with $ver";
+    if (($rev == 1 && $mp_ver >= 1.99) ||
+        ($rev == 2 && $mp_ver <  1.99)) {
+        error "Found mod_perl/$mp_ver, but it can't be used with $ver";
         Apache::TestRun::exit_perl(0);
     }
 

Mime
View raw message