httpd-test-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aa...@apache.org
Subject cvs commit: httpd-test/flood STATUS CHANGES
Date Tue, 04 Dec 2001 16:29:18 GMT
aaron       01/12/04 08:29:18

  Modified:    flood    STATUS CHANGES
  Log:
  Did some work a week or two ago.
  
  Revision  Changes    Path
  1.29      +2 -1      httpd-test/flood/STATUS
  
  Index: STATUS
  ===================================================================
  RCS file: /home/cvs/httpd-test/flood/STATUS,v
  retrieving revision 1.28
  retrieving revision 1.29
  diff -u -r1.28 -r1.29
  --- STATUS	2001/12/04 10:43:23	1.28
  +++ STATUS	2001/12/04 16:29:18	1.29
  @@ -1,5 +1,5 @@
   flood STATUS:							-*-text-*-
  -Last modified at [$Date: 2001/12/04 10:43:23 $]
  +Last modified at [$Date: 2001/12/04 16:29:18 $]
   
   Release:
   
  @@ -35,6 +35,7 @@
   
       * SEGVs when /tmp/.rnd doesn't exist are bad. Make it configurable
         and at least bomb with a good error message. (See Doug's patch.)
  +       Status: This is fixed, no?
   
       * If APR has disabled threads, flood should as well. We might want
         to have an enable/disable parameter that does this also, providing
  
  
  
  1.25      +27 -0     httpd-test/flood/CHANGES
  
  Index: CHANGES
  ===================================================================
  RCS file: /home/cvs/httpd-test/flood/CHANGES,v
  retrieving revision 1.24
  retrieving revision 1.25
  diff -u -r1.24 -r1.25
  --- CHANGES	2001/12/04 10:08:30	1.24
  +++ CHANGES	2001/12/04 16:29:18	1.25
  @@ -9,6 +9,33 @@
   * Detect when we have a https URL and don't have SSL support built in.
     [Justin Erenkrantz]
   
  +* Fix longstanding bug that was probably leaking massive file descriptors
  +  when SSL was being used.  [Aaron Bannert]
  +
  +* Always link the runtime library search path into our binary for
  +  libararies like APR, APR-UTIL, etc.  [Aaron Bannert]
  +
  +* Conditionally compile SSL support (set with the --enable-ssl parameter).
  +  We no longer require SSL to build flood.  [Aaron Bannert]
  +
  +* SSL is now disabled by default and must be explicitly enabled.
  +  This is to comply with certain legal restrictions.  [Aaron Bannert]
  +
  +* Require openssl 0.9.6 or greater. (This may be raised to 0.9.6b if
  +  rumors of lower versions crashing under load become true.)
  +  [Aaron Bannert]
  +
  +* If SSL is enabled we now check that we have the appropriate headers
  +  and libraries available.  [Aaron Bannert]
  +
  +* Rework of --with-openssl parameter to work with the new --enable-ssl
  +  param. There are three ways to use an installed openssl: if it
  +  exists in the default places, if you specify CFLAGS/LDFLAGS to
  +  the configure script, or if you specify the path prefix to the
  +  installation with this new parameter.  [Aaron Bannert]
  +
  +* Add new parameter (--enable-ssl). [Aaron Bannert]
  +
   * Display URL that failed when we get an error.  [Justin Erenkrantz]
   
   * Add support for platforms that do not have threads (or are unusable by APR).
  
  
  

Mime
View raw message