httpd-packagers mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: help with Vista UAC issues [was: Looking for Vincent Bray]
Date Tue, 21 Aug 2007 17:05:22 GMT
Jon Schwartz (NT) wrote:
> Bill,
> 
> 	It looks like the issue actually boils down to mismarked custom actions in the package.
 Specifically, the following custom actions are marked to run on behalf of the user (i.e.,
non-elevated), rather than on behalf of the machine (i.e., elevated):
> 
> 	Custom Action			Current Type			"Promoted" Type (i.e., elevated equivalent)
> 	----------------------------------------------------------------------------------------------------------------------------------
> 	SelfRemoveService		1106				3154
> 	SelfStopService		1106				3154
> 	InstallConfFiles			1602				3650
> 	RemovePriorService		1618				3666
> 	SelfInstallService		1618				3666
> 	SelfStartService		1746				3794
> 	StartApacheMonitor		1746				3794
> 
> 	(Note that SelfStartService and StartApacheMonitor only require elevation since interactive
users don't have SERVICE_START permissions on the service)

DOH!

> 	I made these changes to generate the attached MSI transform from the package and verified
that the install runs through without any of the "access denied" issues that hit before (i.e.,
Apache2 service is created, etc).

Thanks for validating.  I'll apply these changes to our packages.  We
appreciate this a ton!

> P.S.  Do you also deal with the ApacheMonitor, or is that a different group/alias?  I'd
like to help get that Vista-ready as well.

You'll be glad to know we already picked that up.  No API changes at all,
just a shortsighted 'bail if we don't recognize the Win32 os version'.

We solved that permanently (well, until there is a significant API change ;-)
and it's being rolled out in the next release, already.

Thank you again for your help and detailed review!

Bill

Mime
View raw message