httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prakash Premkumar <prakash.p...@gmail.com>
Subject Re: Linking sqlite in to apache module
Date Mon, 13 Jul 2015 13:11:34 GMT
Can someone kindly help me with this ?

On Mon, Jul 13, 2015 at 3:41 PM, Prakash Premkumar <prakash.prax@gmail.com>
wrote:

> Thanks for your reply Dirk,
>
> I made the changes you specified :
>
> Here's the source code for the new module :
> http://pastebin.com/q4KQfhBQ
>
> It gets only till line no 78 in the handler. (The first log)
>
> That it before calling the first sqlite function sqlite3_open()
>
>
> On Mon, Jul 13, 2015 at 2:41 PM, Dirk-Willem van Gulik <
> dirkx@webweaving.org> wrote:
>
>> On 13 Jul 2015, at 10:21, Prakash Premkumar <prakash.prax@gmail.com>
>> wrote:
>> > I'm trying to call sqlite function from my apache module.
>> >
>> > The source code for the module can be found here:
>> > http://pastebin.com/zkbTf03J
>> ..
>> > When I navigate to localhost/ : I get It Works! message
>> >
>> > But when I naviage to any other URL like localhost/asd
>> >
>> > I get  the following response
>> >
>> > No data received
>> >> ERR_EMPTY_RESPONSE
>>
>> You may want to set a
>>
>>          ap_set_content_type(r, "text/html");
>>
>> before ap_rput()ing data. Secondly I woud sprinkle a few lines like:
>>
>>     ap_log_perror(file, line, APLOG_MODULE_INDEX, APLOG_NOTICE, 0,
>>                 r->pool, “Past %s:%d", __FILE__, __LINE__);
>>
>> in your code - to see where it gets in the hook handler. Tail the error
>> log to see what is going on.
>>
>> Dw.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message