httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McCracken <Tim.mccrac...@Mccrackenco.com>
Subject RE: tcp/ip sockets in apache module
Date Tue, 17 Jun 2014 13:16:01 GMT

I have a module that does this in Windows. I used code right off the MSDN site for a TCP/IP
client.

Did you remember to do "wsastartup"?



-----Original Message-----
From: Jeff Trawick [mailto:trawick@gmail.com] 
Sent: Friday, May 23, 2014 1:14 PM
To: modules-dev@httpd.apache.org
Subject: Re: tcp/ip sockets in apache module

On Fri, May 23, 2014 at 1:58 PM, Jeremy Thompson <jeremy@warehousesports.com
> wrote:

> I'Ll give that a shot.  I'Ve used source level debugging in IDE's but 
> it looks like I'Ll be using GDB for this one. Thanks.
>

Have a look at

http://httpd.apache.org/dev/debugging.html

On Windows, you can start httpd normally and attach to the httpd child process from the Visual
Studio IDE in order to debug.


>
>
>
>
>
> On 5/23/14 10:41 , "Jeff Trawick" <trawick@gmail.com> wrote:
>
> >On Fri, May 23, 2014 at 1:27 PM, Jeremy Thompson 
> ><jeremy@warehousesports.com
> >> wrote:
> >
> >> I'm trying to write a module for apache.  I've successfully compile 
> >>in a  test module that doesn't do a whole lot yet.  I would like to 
> >>be able to  use  tcp/ip sockets in the module to talk to another 
> >>server.  I added in some  test code that should connect to my 
> >>listening server and say hello whenever  a request is made.  I'm not 
> >>getting any errors upon compiling the module  with the sockets stuff 
> >>added but its not actually doing anything.
> >>  Basically
> >> its ignoring my connect and send code.  Does anyone have a small 
> >>working  example of this or am I just way off base in using TCP/IP 
> >>for external  communication to a module.  Thanks.
> >>
> >> ~Jeremy
> >>
> >>
> >You need to know how to step through your code with a source level 
> >debugger so you can figure out these sorts of problems on your own.
> >
> >Do you know how to do that?  Are you trying but it isn't stopping in 
> >your code?  Is there some other issue with source level debugging?
> >
> >--
> >Born in Roswell... married an alien...
> >http://emptyhammock.com/
> >http://edjective.org/
>
>
>
>


--
Born in Roswell... married an alien...
http://emptyhammock.com/
http://edjective.org/
Mime
View raw message