httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hong <h...@cornell.edu>
Subject problem with different version of openssl in Apache and apache module
Date Thu, 19 Dec 2013 19:29:47 GMT
I wrote an Apache module that call functions in openssl library to sign the
messages. The module is dynamic linked to openssl library 1.0.1d when I
built it. It works fine when it is loaded into the Apache that was also
built with the same version of openssl. But if Apache was built with openssl
0.9.8x, segfault occurred. Is there anything I can do for my built so it
also works in the Apache which was built with older version of openssl?

Thanks for any advice, 

Hong



--
View this message in context: http://apache-http-server.18135.x6.nabble.com/problem-with-different-version-of-openssl-in-Apache-and-apache-module-tp5010925.html
Sent from the Apache HTTP Server - Module Writers mailing list archive at Nabble.com.

Mime
View raw message