httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: AP_INIT_TAKEn macros / gcc 4.6.3?
Date Tue, 24 Jul 2012 17:44:37 GMT
On 24.07.2012 19:23, Cantor, Scott wrote:
> I'm seeing a build bug on a Solaris box with a very recent GCC version against the Apache
2.4 headers, which I'm wondering about.
>
> All my AP_INIT_TAKE1 macros for command handling are failing with:
> error: expected primary-expression before '.' token
>
> Looking at the macros, it's doing some kind of union initialization that I'm thinking
might have broken. My module is in C++, so it's a g++ issue, possibly.
>
> This code has built/is building on many other compiler, platform, and Apache combinations
dating back to Apache 2.0 and 2.2 and gcc versions all the way back to 3.2 or so. I also have
a BSD box that works ok with the 2.2 headers and GCC 4.2. So it might be a very recent issue.
>
> I'm still investigating, just wondering if anybody has seen this.

I can confirm, that I am able to build httpd 2.4 on Solaris using gcc 
4.7.1. I vaguely remember that I had also done it using 4.6.3. In my 
case no g++ involved though. That points in that direction as a possible 
cause.

Regards,

Rainer


Mime
View raw message