httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From david jone <davidjone2...@gmail.com>
Subject centOS apache module Vs. ubuntu apache module
Date Fri, 19 Aug 2011 04:22:12 GMT
Hello,
       everyone,recently I have a problem that a apache module developed on
ubuntu with apxs2 can't work on CentOS.
The more details as follows:
1. The module thar first developed on Ubuntu OS with apache2 v2.2.14 using
apxs2 compile tools, and then worked well. And I use AP_INIT_TAKE1 to fetch
module argument.
    All above is worked well.
After then, first I directly move the compiled apache2 module .so file to
centOS with apache2 v2.2.19.When I add LoadModule XXXXXX.so, and restart
apache2.As a result, an error message given that "ELF format wrong".
2.And I recompile the module with all source files via apxs (not apxs2 on
ubuntu), and add LoadModule directive XXXXXX.so, and restart apache2.
Apache2 is started smoothly,but the module's argument are
 not fetched right!

I wanna that whether there are differences between apxs and apxs2.And I also
want to know why the module on centOS can't fetch module argument right.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message