httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From whut_jia <whut_...@163.com>
Subject Re:Re: how to add mod_session_crypto into apache
Date Thu, 25 Nov 2010 11:14:30 GMT

At 2010-11-25 18:05:55,"Rainer Jung" <rainer.jung@kippdata.de> wrote:

>On 25.11.2010 03:30, whut_jia wrote:
>> At 2010-11-24 22:15:43,"Rainer Jung"<rainer.jung@kippdata.de>  wrote:
>>
>>> On 24.11.2010 13:57, whut_jia wrote:
>>>> Hi,
>>>> I want to add mod_session_crypto  into my apache server, so I run this command
below for configuring the source tree:
>>>> ./configur --prefix=/usr/local/apache2.3 --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr
  --enable-mods-shared="all session_crypto"
>>>> But there are always these errors :
>>>>      checking apr_crypto.h usability ... no
>>>>      checking for apr_crypto.h ... no
>>>>      configure WARNING : Your APR does not include SSL/EVP        support
>>>>
>>>>
>>>>    I can't find  this file(crypto.h) in my APR directory,so I copy this file
from APR website into my APR include directory.But these errors are not still resolved.
>>>> What should I do?
>>>
>>> mod_session_crypto needs crypto support in APR/APU. There is no version
>>> of APR or APU released until now, which has that support. If you want to
>>> experiment with mod_session_crypto, you need to either build apr-util
>>> (APU) from the head of the 1.4.x branch (and using e.g. the latest
>>> released APR 1.4), or using APR trunk, which contains APR and the
>>> previously separately released APU.
>>>
>>> APU 1.4.x is available for svn checkout at
>>>
>>> http://svn.apache.org/repos/asf/apr/apr-util/branches/1.4.x/
>>>
>>> and if you prefer that way APR trunk is available at
>>>
>>> http://svn.apache.org/repos/asf/apr/apr/trunk/
>>>
>>> Note that these are not released yet. To build them you will need a
>>> toolchain containing e.g. autoconf and run the buildconf scripts
>>> contained in the checkout.
>>>
>>> There's no way to add crypto support to your already existing
>>> /usr/local/apr.
>>>
>>> Regards,
>>>
>>> Rainer
>>
>> Oh,My APR's version is released apr-1.4.2 .How do i build  apr-util  from the head
of the 1.4.x branch.What is the 1.4.x branch,and where  I can download the 1.4.X branch source
code.
>
>First remember that APU 1.4 hasn't been released yet. You might use it 
>for testing and development, but think twice before using it for production.
>
>There is no download available. You have to checkout using subversion.
>
>To build you will need a slightly extended toolchain including m4, 
>autoconf and automake on your system.
>
>Build steps:
>
>1) Checkout APU from subversion
>
>svn checkout http://svn.apache.org/repos/asf/apr/apr-util/branches/1.4.x/
>
>2) Provide APR sources
>
>Download and extract apr sources (latest released 1.4 version) available 
>at http://apr.apache.org/.
>
>3) Go to the APU checkout directory and run
>
>./buildconf --with-apr=/path/to/your/apr/1.4/sources
>
>4) Run configure, make, make install
>
>Check options using
>
>./confgure -help
>
>then run configure with your preferred options (or without any).
>
>Finally as usual
>
>make
>make check
>make install
>
>Regards,
>
>Rainer

Hi , Rainer,Thank you very much!
I did it as the same as what your said,but  when I make my apache server source code after
running configure command,there is an error:
    #error Crypto support must be enable in APR
{  My using APU(apr-util-1.4.x_20101125031405.tar.gz) is downloaded from http://svn-master.apache.org/snapshots/apr-util-1.4.x/
,I build it with the following command:
            ./buildconf --with-apr=/usr/local/apr
            ./configure --prefix=/usr/local/apr --with-crypto
              make;make install
          
APR's version is apr1.4.2;


I compile my apache source code with the following commmad,
         ./configure --prefix=/usr/local/apache2.3 --with-apr=/usr/local/apr  --with-apr-util=/usr/local/apr
--enable-mods-shared="all proxy session_crypto"
} 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message