httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Meyer <mwm-keyword-apache.b9a...@mired.org>
Subject Possible bug in rules.mk?
Date Fri, 24 Sep 2010 12:58:46 GMT
In trying to get my module makefiles working properly, I noticed two
things that seem to be at odds with each other (this is the 2.2
distro; apologies if it's fixed later):

1) modules.mk typically makes the *.la file depend on the *.slo files.
2) build/rules.mk in the distro changes the output of mkdepend from
   .o: to .lo:, meaning the .lo files now depend on the results.

But with that modules.mk, nothing depends on the .lo files. So
dependencies in the .deps file generated by this depend: rule won't
cause anything to be built, because nothing depends on the .lo files
(they get built as a side effect of building the .slo files via
SH_*_COMPILE rules) that they have dependencies for.

This is easy to check - make sure your dependencies are up to date and
everything is built, touch a .h file, and try running make again.
Nothing builds.

Changing the .lo: to .slo: in rules.mk and trying the same experiment
caused the expected behavior - the rebuilding of the various dependent
files.

Or am I overlooking something here?

   Thanks,
   <mike
-- 
Mike Meyer <mwm@mired.org>		http://www.mired.org/consulting.html
Independent Network/Unix/Perforce consultant, email for more information.

O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

Mime
View raw message