httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Lewis" <...@joe-lewis.com>
Subject RE: Fighting with build process 2.2.x on Sparc Solaris 10
Date Sat, 06 Mar 2010 15:31:19 GMT
On Fri, March 5, 2010 3:41 pm, Thomas, Peter wrote:
> Getting further [in addition to pulling down the obvious additional
> dependency, libnet]:
>

[snip]

>
> Undefined                       first referenced
>  symbol                             in file
> __divdi3                            server/.libs/libmain.a(util_time.o)
> (symbol belongs to implicit dependency /usr/local/lib/libgcc_s.so.1)
> __moddi3                            server/.libs/libmain.a(util_time.o)
> (symbol belongs to implicit dependency /usr/local/lib/libgcc_s.so.1)
> __ashldi3                           server/.libs/libmain.a(core.o)
> (symbol belongs to implicit dependency /usr/local/lib/libgcc_s.so.1)
> __ashrdi3                           server/.libs/libmain.a(core.o)
> (symbol belongs to implicit dependency /usr/local/lib/libgcc_s.so.1)
> ld: fatal: Symbol referencing errors. No output written to httpd

Those "undefined symbols" errors talk about the symbol belonging to an
implicit dependency, libgcc_s.so.1.  A quick google search shows that you
are having trouble with libgcc.a.

Just an additional note, you might want to try the users list, not the
third-party modules devel list.  That list will relate much better to
compiling apache rather than to developing modules.

Joe


Mime
View raw message