httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: I'm stuck with an OS X module problem and -mmacosx-version-min=10.5
Date Tue, 17 Nov 2009 04:18:02 GMT
Patrick McManus wrote:
> 
> Of course, the SL binary will not run on 10.5 - I get linker errors when
> apache loads it. That's expected (ok, I forgot it, but its normal) - and
> then I rebuilt the module with -mmacosx-version-min=10.5.
> 
> The linker errors resolved themselves. Hurrah.
> 
> However now the module is broken for me. The handler will run and
> the right content-body will flow out, but content-type is consistently
> text/plain even though ap_set_content_type(r, "text/html") has been
> called.

You mixed up httpd by detecting 10.6, doesn't matter what you told the
compiler to do after configure.  Try

CC="gcc -mmacosx-version-min=10.5" ./configure

or something like that.

Mime
View raw message