httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick McManus <mcma...@ducksong.com>
Subject Re: I'm stuck with an OS X module problem and -mmacosx-version-min=10.5
Date Tue, 17 Nov 2009 14:45:56 GMT
William, thanks for the response.

A clearer way of asking my question: "How do I (can I?) build a single
binary module that runs on both OS X 10.5 and 10.6 with the standard
apache package found on those systems - they are 2.2.11 and 2.2.13
respectively". 

Creating such a full executable (unrelated to apache) is easy,
-mmacosx-version-min=10.5 does the trick but that is giving me problems
with a module.

On Mon, 2009-11-16 at 22:18 -0600, William A. Rowe Jr. wrote:
> You mixed up httpd by detecting 10.6, doesn't matter what you told the
> compiler to do after configure.  Try
> 
> CC="gcc -mmacosx-version-min=10.5" ./configure
> 
> or something like that.

This advice applies to the building of the Apache Server itself, not my
module - right? I want to work with the standard apache packages
included in Leopard and Snow Leopard, not build and distribute them
myself.








Mime
View raw message