httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Langly <richard.ringo.lan...@gmail.com>
Subject helloworld module won't load
Date Tue, 31 Mar 2009 05:44:30 GMT
I'm running gentoo and trying to see my helloworld module which I got
from the apache modules book. So I try to hit
http://10.0.2.20/helloworld, but nothing happens exept that I get a
'file does not exist' in the apache errors.log.

When I run "apache2 -M", I don't see my module listed anywhere's. My
module compiled and installed fine in /usr/lib64/apache2/modules when
I did a 'apxs -cia mod_helloworld.c'

Here's the file located in /etc/apache2/modules.d/
---
LoadModule helloworld_module    modules/mod_helloworld.so

<Location /helloworld>
    SetHandler helloworld
</Location>
---

I've also tried many other combinations of -D HELLO to the APACHE_OPTS
line in /etc/conf.d/apache2 (just like the other gentoo module *.conf
files, and restarted the server, but nothing has worked.

I've done everything the book said, and all seems fine, except I see
nowhere's that my module has loaded.

Mime
View raw message