httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Antwort: apxs
Date Thu, 05 Feb 2009 13:14:27 GMT
Hi Michele,

try another order of your library flags (e. g. -lcrypt before 
-lmysqlclient). This often helps on some platforms... 


Pierre Heim

Mindlab Solutions GmbH
Marktplatz 19
D-73728 Esslingen am Neckar / Germany

fon +49.711.36550.206
fax +49.711.36550.555

Amtsgericht Stuttgart HRB 720637 | Ust-ID: DE 233844568
Geschäftsführer: Uli Häfele - Susanne Köhler - Heinz D. Schultz

Online Value Forum Februar 2009 in Düsseldorf, Hamburg und Stuttgart 

- Forum mit Top-Referenten – Umsatzoptimierungsstrategien im Web
- Future Trends und Customer Experience – Targeting, Mobile Channels und 
- Jetzt anmelden unter 
multiply your onsite value!

This message is for the designated recipient only and may contain 
privileged, proprietary, or otherwise private information. If you have 
received it in error, please notify the sender immediately and delete the 
original. Any other use of the email by you is prohibited. 

"Michele Waldman" <> 
02.02.2009 17:18
Bitte antworten an



I wrote the mod_auth_digest authenticating against mysql.


I can't compile.

apxs -i -a -I/usr/include/mysql -L/usr/lib/mysql -lmysqlclient -luuid -lrt
-lcrypt -lm -lz -c mod_auth_digest.c

I've tried using an extra -I and -L for crypt.

When I compile with both, I get crypt is an undefined symbol.

When I run apxs, I get the message:
If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/'

I've tried setting the environment variables, modifying /etc/ 
-WI, but it's still not working.

Does anyone know how to compile with libraries?


Other modules are compiling with crypt.  I can't figure out where I'm 
wrong here.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message