httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michele Waldman" <mmwald...@nyc.rr.com>
Subject apxs
Date Mon, 02 Feb 2009 16:18:58 GMT
I wrote the mod_auth_digest authenticating against mysql.

 

I can't compile.


apxs -i -a -I/usr/include/mysql -L/usr/lib/mysql -lmysqlclient -luuid -lrt
-lcrypt -lm -lz -c mod_auth_digest.c



I've tried using an extra -I and -L for crypt.


When I compile with both, I get crypt is an undefined symbol.

When I run apxs, I get the message:
If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'

I've tried setting the environment variables, modifying /etc/ld.so.conf and
-WI, but it's still not working.

Does anyone know how to compile with libraries?

 

Other modules are compiling with crypt.  I can't figure out where I'm going
wrong here.

 

Michele


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message