httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shibu Narendranathan" <shi...@sonimtech.com>
Subject RE: Antwort: Need help with --activate-module
Date Thu, 29 Jan 2009 07:57:58 GMT
Thankyou Pierre ! That helped a lot !!

 

You are right, the book instructions are for Apache 1.3x.

I could compile and install my example mod.

I have a question though. As per the instructions, I could compile and
install properly, but how do I see the output on my browser?

 

I did the following:

1. # apxs -g -n foo

2. # cd foo

3. # apxs -c mod_foo.c

4. # apxs -i -a -n "foo" mod_foo.la

5. # apachectl restart

6. # http://173.17.15.1/  -> shows me the "It works" page

7. # http://173.17.15.1/foo  &  http://173.17.15.1/foo_module  -> none
of this works.

 

I also tried adding following to 

<Location /foo>

SetHandler foo_handler

</Location>

 

Am I missing something here ?

 

Thanks in advance,

Shibu.

 

 

  _____  

From: pierre.heim@mindlab.de [mailto:pierre.heim@mindlab.de] 
Sent: Wednesday, January 28, 2009 6:04 PM
To: modules-dev@httpd.apache.org
Cc: modules-dev@httpd.apache.org; Shibu Narendranathan
Subject: Antwort: Need help with --activate-module

 


Hi, 

I don't know the book but a look to Google says that it seems to refer
Apache 1.3.x. If you don't need a static module take a look to the apxs
script (http://httpd.apache.org/docs/2.2/de/programs/apxs.html
<http://httpd.apache.org/docs/2.2/de/programs/apxs.html> ) otherwise
check a shipped module as a reference. Note that also the API has
changed to Apache 2.x.. 

Pierre



"Shibu Narendranathan" <shibun@sonimtech.com> 

28.01.2009 12:34 

Bitte antworten an
modules-dev@httpd.apache.org

An

<modules-dev@httpd.apache.org> 

Kopie

"Shibu Narendranathan" <shibun@sonimtech.com> 

Thema

Need help with --activate-module

 

 

 




Hi All,

I am a newbie to apache modules and having trouble adding a new module
of my own. So any help would be very much appreciated.

I am referring the book "Writing Apache Modules with Perl and C" by
Lincoln Stein & Doug MacEachern and I am trying to write a module in C.
In the book, it is mentioned to use the following to get the new module
activated:

% ./configure --activate-module=src/modules/site/mod_hello.c \
--enable-module=hello

I get  the following error:
configure: error: 
unrecognized option: --activate-module=src/modules/site/mod_hello.c
Try `./configure --help' for more information.

On trying ./configure -help,  I did not find the option
"--activate-module"
I am working on version Apache/2.2.11.

I tried searching on net and in the archives of this mailing list
(http://marc.info/?l=apache-modules <http://marc.info/?l=apache-modules>
), but could not find any answer. 

Thanks in advance,
Shibu Narendranathan.




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message