httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bray <Tim.B...@Sun.COM>
Subject Unable to build for some stupid reason
Date Thu, 11 Sep 2008 19:52:43 GMT
Wanted to refresh apr & httpd, grabbed tarballs of both, did this:

Build apr

   614  CFLAGS=-g ./configure --prefix=/usr/local/apr
   615  make
   616  sudo make install

build httpd

   636  CFLAGS=-g ./configure --with-apr=/usr/local/apr --prefix=/usr/ 
local/apache2
   637  make

lots of stuff compiles, then...

Kaboom!

gawk -f /Users/twbray/dev/apache/build/make_exports.awk `cat  
export_files` > exports.c
/usr/local/apr/build-1/libtool --silent --mode=compile gcc   -g  - 
DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp    -I/Users/ 
twbray/dev/apache/srclib/pcre -I. -I/Users/twbray/dev/apache/os/unix - 
I/Users/twbray/dev/apache/server/mpm/prefork -I/Users/twbray/dev/ 
apache/modules/http -I/Users/twbray/dev/apache/modules/filters -I/ 
Users/twbray/dev/apache/modules/proxy -I/Users/twbray/dev/apache/ 
include -I/Users/twbray/dev/apache/modules/generators -I/Users/twbray/ 
dev/apache/modules/mappers -I/Users/twbray/dev/apache/modules/database  
-I/usr/local/apr/include/apr-1 -I/usr/include/apr-1 -I/Users/twbray/ 
dev/apache/modules/proxy/../generators -I/Users/twbray/dev/apache/ 
modules/ssl -I/Users/twbray/dev/apache/modules/dav/main  -prefer-non- 
pic -static -c exports.c && touch exports.lo
exports.c:1636: error: redefinition of 'ap_hack_apr_allocator_create'
exports.c:722: error: previous definition of  
'ap_hack_apr_allocator_create' was here
exports.c:1637: error: redefinition of 'ap_hack_apr_allocator_destroy'
exports.c:723: error: previous definition of  
'ap_hack_apr_allocator_destroy' was here

... thousands more errors ...

Quite likely I did something stupid, any suggestions?  -T

Mime
View raw message