httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subra A Narayanan" <aswat...@gmail.com>
Subject Re: debugging a timeout issue
Date Fri, 09 May 2008 02:33:28 GMT
Hey Sam,

I am not an apache expert but you can start off with a tool like wireshark
to see if the request is even leaving the client machine. Its a great tool
to debug such problems.

Subra

On Thu, May 8, 2008 at 10:24 PM, Sam Carleton <scarleton@miltonstreet.com>
wrote:

> I am a one man ISV that is using an Apache and an Apache Module.  I am
> trying to trouble shoot a timeout issue that I cannot see, my customer
> is reporting the problem and he can consistently repeat the problem.
> Sometimes when the .Net 2.0 client makes a call to my Apache module,
> the .Net code times out, I am trying to figure out which side is
> having problems.  I am thinking it is a .Net, but I wanted to make
> sure that I throughly confirmed that it is not Apache.
>
> I have logged the heck out of my apache module and it never gets called.
> I have set apache's LogLevel to debug and turned on access logging,
> but I never see the request come in.  I see the first one, but not the
> second one.
>
> Is there anything else I can do to increase the logging of Apache or
> is it safe to say that the request is NOT leaving the .Net
> application?  Any suggestions on how I can absolutely confirm the
> issue is in the .Net client?
>
> Sam
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message