httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samuel Gómez <e6973...@est.fib.upc.edu>
Subject Building a module for Apache 2.2
Date Sun, 30 Mar 2008 04:43:39 GMT
Hi All.

I am trying to do my first module (mod_brokenlink). I was using Apache 
2.0.63 and the instructions in 
http://threebit.net/tutorials/apache2_modules/tut1/tutorial1.html to 
compile my module and everything was right.

Now I have removed Apache 2.0.63 from where it was and I installed 
Apache 2.2.8 in the same location.

My problem comes on building the module. Specifically on "make", I get 
this output:

In file included from /home/...../apache2/include/apr_strings.h:48,
from mod_brokenlink.c:4:
/home/...../apache2/include/apr.h:273: error: expected ‘=’, ‘,’, ‘;’, 
‘asm’ or ‘__attribute__’ before ‘apr_off_t’
In file included from mod_brokenlink.c:4:
/home/....../apache2/include/apr_strings.h:299: error: expected 
declaration specifiers or ‘...’ before ‘apr_off_t’

And many other errors almost identical.

Should it work as before or I am doing something wrong? I tried to 
google some info on apache 2.2 module building but I didn't found 
anything useful. Where is this info supposed to be?

Thanks a lot!

Samuel



Mime
View raw message