httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: Building a module for Apache 2.2
Date Sun, 30 Mar 2008 09:24:51 GMT
On Sun, 30 Mar 2008 06:43:39 +0200
Samuel Gómez <e6973591@est.fib.upc.edu> wrote:

> My problem comes on building the module. Specifically on "make", I
> get this output:

Are you using make without apxs?

Use the apxs for your apache, and it will ensure you have all the
right DEFINEs for your system.  That applies to all apache versions.

> In file included from /home/...../apache2/include/apr_strings.h:48,
> from mod_brokenlink.c:4:
> /home/...../apache2/include/apr.h:273: error: expected ‘=’, ‘,’, ‘;’, 
> ‘asm’ or ‘__attribute__’ before ‘apr_off_t’

That'll be because you've got largefile (>2Gb) support enabled
on 2.2 (where it's a default).

-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

Mime
View raw message