httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Lewis <...@joe-lewis.com>
Subject Re: http-redirect url gets corrupted in request_rec - apache 2
Date Mon, 10 Dec 2007 19:03:45 GMT
Please Stop Top Posting.

SAILESH KRISHNAMURTI, BLOOMBERG/ 731 LEXIN wrote:
> just finished trying that. Same result still seems to have the same garbage characters.
Is there any other debugging technique we can try. Can we force nulll termination of strings.
Are we sure it is a non-null terminated string issue, since the characters are occuring in
the begining of the string. In the past, I think I have noticed them occuring in the middle
also ...
>   

We are NOT sure whether or not it is a NULL termination issue at this
point.  Whatever it is would actually be a result of the variable that
occurs BEFORE the table in physical memory.  It looks like the first
segment of the header is getting overwritten.  You may want to try using
a debugger at this point, since you had the same results with your
module hooking to *_LAST.  Using a debugger, you would have to find the
table header, and then step through while watching that until you see it
change, then do a back trace to find out where the service is.  (hint,
in Linux, you would have used "gdb httpd2", then "run -X", then start
tracing when you hit it with a browser, but in Solaris, I believe you
will have to use strace or something similar).

Joe
-- 
Joseph Lewis <http://sharktooth.org/>
"Divide the fire, and you will sooner put it out." - Publius Syrus

Mime
View raw message