httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hammer, Tim" <>
Subject (resend) RE: mod_ssl
Date Fri, 14 Dec 2007 02:50:46 GMT

Is there no one with any info or did I not ask my question in a proper
manner? Could someone at least acknowledge that this message is seen?

I am attempting to upgrade httpd from 1.3.x to 2.2.x for our web
application. I have managed to get everything building and working,
except SSL support. seems to load alright, but at some point
I get a core dump (one occurred during startup/initialization I think,
but I do get servers running; however, when I try to access a page from
a browser, everything dumps again).
All of the core dumps look the same:
Program terminated with signal 11, Segmentation fault.
#0  apr_bucket_shared_destroy (data=0x0) at
47      buckets/apr_buckets_refcount.c: No such file or directory.
        in buckets/apr_buckets_refcount.c
(gdb) bt
#0  apr_bucket_shared_destroy (data=0x0) at
#1  0xb7fc9b61 in heap_bucket_destroy (data=0x0) at
#2  0xb7f67579 in bio_filter_in_read () from
#3  0x0000000b in ?? () from /lib/

As you can see, the call from into the buckets/ code is
passing a null pointer. None of our other modules have been modified to
use buckets. Does mod_ssl require the use of buckets?
Thanks for any info!
Xerox Corporation, Office Group 

Phone: 585/427-1684 
Fax:     585/427-3244 
Addr:  M/S 0801-80A 
           1350 Jefferson Road 
           Rochester, NY  14623 

This e-mail message, including any attachments, is for the sole use of
the intended recipient(s) and may contain confidential information. Any
unauthorized review, use, disclosure or distribution is prohibited. If
you are not the intended recipient(s) please contact the sender by reply
e-mail and destroy all copies of the original message.
Thank you.

View raw message