httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Lewis <...@joe-lewis.com>
Subject Re: Need Help <-- fix this, please
Date Tue, 20 Nov 2007 14:22:55 GMT
Subhash KK. wrote:
>
> Hello All..
>
>  
>
> I need small help in getting some info. I am restarting the network in
> linux after changing the ip settings through a cgi (cgi in c) program.
> Before I issue the command (“/etc/init.d/networking restart” in
> Debian), I am sending response back to the client through printf.. But
> apache is not able to process that data to the client. Has some one
> faced this problem ? Any solution for this.
>
>  
>
> Please help.
>
> Thanks in Advance..
>
>  
>
> Thanks and Regards
>
> Subhash K K
>
>  
>

1 - Did you get the wrong mailing list, or is there a third party apache
module communicating with the CGI that you need help with and that we do
not know about?

2 - I almost deleted this message thinking it was a Nigerian oil tycoon
looking for my bank account information to transfer funds.  Please
ensure that the subject line is corrected before replying to any
responses - or you may never get responses when the messages hit the bit
buckets.  In fact, please feel lucky if you get any additional responses
at all.

3 - If a TCP connection results in restarting the network, that network
restart will terminate all open TCP connections as it disables any
network cards.  Hence, it results in exactly what you see - suddenly
apache cannot communicate with the client.

Some additional reading material (if you ever get bored) might be :

http://www.gweep.ca/~edmonds/usenet/ml-etiquette.html#SECTION00030000000000000000
http://www.catb.org/~esr/faqs/smart-questions.html

-- 
Joseph Lewis <http://sharktooth.org/>
"Divide the fire, and you will sooner put it out." - Publius Syrus

Mime
View raw message