httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralf Mattes ...@seid-online.de>
Subject Re: Versioning a module?
Date Tue, 04 Sep 2007 21:13:45 GMT
On Sat, 2007-09-01 at 09:39 -0700, Tim Bray wrote:
> I'm getting towards the point where I'm going to bless a build of  
> mod_atom as 0.5 or something and actually encourage people to use it.
> 
> So... is there a convention on how to version a module?  Presumably  
> there are cases where a client would like to query the module  
> version?  

Really? I'd guess that most often one wants/needs to query the protocol
version of a module. After all, the module version doesn't matter as
long as it behaves in a defined way. I usually emmit a protocol version
header for all modules that support a defined API/protocol. You could
require the client to do the same (i.e. send a 'X-need-foo-version: >2'
header with the request).

 Cheers, Ralf Mattes
 
>   -Tim


Mime
View raw message