httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Farokh Irani <far...@mcfsoftware.com>
Subject Re: APXS issue.
Date Wed, 18 Jul 2007 12:22:47 GMT
>On Wed, 2007-07-18 at 07:23 -0400, Farokh Irani wrote:
>
>>  I used the same command apxs -ic -S CC=g++ -n mod_fancy mod_fancy.cpp
>>  config.cpp
>>  (note that this is what had been suggest on this list a while back).
>>  Here is what happened when I ran apxs:
>>
>>  devlinux# apxs -ic -S CC=g++ -n mod_fancy mod_fancy.cpp config.cpp
>>  /usr/local/build-1/libtool --silent --mode=link g++ -o mod_fancy.la
>>  -rpath /usr/local/libexec/apache22 -module -avoid-version
>>  mod_fancy.cpp config.cpp
>
>Oh - that's strange: it seems like your apxs-invocation skipped the
>actual compilation step (the first line should start like
>"/usr/local/build-1/libtool --silent --mode=compile .....").
>Is it possible that your object code files  are newer than the source
>files? Have a look into the '.libs' directory). Maybe you should clean
>out your build environment and delete all object files ....

I don't see how, since just before I ran apxs, I used ftp to copy the 
files over (there are only 4 files). I deleted everything from .libs 
and tried it again, but got the same results including the missing 
symbol.
-- 

Farokh
----------------------------------------------------------------------------
MCF Software...simply dependably engineered
Developers of ListSTAR http://www.liststar.com/, MacRADIUS
http://www.macradius.com/, Address List Sorter
http://www.mcfsoftware.com/als/, SimpleText Filter for EIMS
http://www.mcfsoftware.com/stf/ and Auto Reply plug-in for EIMS 
http://www.mcfsoftware.com/ar/.

Mime
View raw message