httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralf Mattes ...@seid-online.de>
Subject Re: APXS troubles
Date Fri, 20 Jul 2007 11:53:01 GMT
On Fri, 2007-07-20 at 12:38 +0100, Jeremy Sowden wrote:
> Farokh Irani wrote:
> > >On Fri, 2007-07-20 at 08:36 +0200, Mike wrote:
> > >> > >         if ($f =~ m|\.c$|) {  <---------------- Here, bad
> > coder! BAD!
> > >> > I don't know perl at all, so those were
> > >> > stabs in the dark. Any pointers on that would be appreciated.
> > >> Try:
> > > > if( $f =~ m/\.c$|\.cpp$|\.cc$/ )
> >
> > OK, I tried this and while it appears to compile and link, the symbol
> > winds up undefined again and nm shows the a similar output as when it
> > was linked as an empty library.
> >
> > >I'd go for:
> > >
> > > if ( $f = ~m/\.c(c|pp){0,1}$/i )
> >
> > This one doesn't compile. When I run apxs, perl complains:
> > Use of uninitialized value in pattern match (m//) at /usr/bin/apxs2
> > line
> > 361.
> 
> There's a typo.  It should be:
> 
>   if ( $f =~ m/\.c(c|pp){0,1}$/i )

Yes, sorry. This was actually caused by a stupid mail client inserting a
line break during copy-n-paste. While correcting this I must somehow
inadvertently have added a whitespace at the wrong point.

 Cheers, RalfD
 
> J.
> --
> +0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+
>   www: http://www.azazel.net/
>   pgp: http://www.azazel.net/~azazel/js_key.asc
> +0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+


Mime
View raw message