httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danie Qian" <dan...@bestningning.com>
Subject Re: mod_authn_dbd - internal server error after certain idle time
Date Sat, 07 Jul 2007 03:19:47 GMT

----- Original Message ----- 
From: "Matthew Kent" <matt@bravenet.com>
To: <modules-dev@httpd.apache.org>
Sent: Friday, July 06, 2007 9:37 PM
Subject: Re: mod_authn_dbd - internal server error after certain idle time


> On Fri, 2007-06-07 at 23:04 +0100, Nick Kew wrote:
>> On Fri, 06 Jul 2007 13:13:03 -0700
>> Matthew Kent <matt@bravenet.com> wrote:
>>
>>
>> > > >> My question is why the keepalive setting for 60sec doesnt work
>> > > >> for me? How
>> > > >> do I fix this without changing the timeout setting on the mysql
>> > > >> server?
>>
>> For future reference, this should really have been on users@.
>> But you've had some good replies here.
>>
>> > > > I've haven't used mod_authn_dbd yet but this sounds similar to
>> > > > issues I was having
>> > > >
>> > > > http://issues.apache.org/bugzilla/show_bug.cgi?id=39329
>> > > >
>> > > > patch hasn't made its way into apr_dbd_mysql.c yet. Please add a
>> > > > note if the it fixes your issue.
>
> After some testing I think I better understand the issue, updated it
> here
>
> http://issues.apache.org/bugzilla/show_bug.cgi?id=39329#c11
>
> think its the mysql_ping reconnection clobbering the prepared statement
> used in mod_authn_dbd.
>
> Danie, which version of MySQL is your apr-util compiled against?
> -- 

Actually this is happenning on mysql-4.1.20-2.RHEL4.1 and another manually 
compiled 5.0.41 mysql server, both 


Mime
View raw message