httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike <dykci...@gmail.com>
Subject Re: Compilation problem on Mac OS
Date Thu, 28 Jun 2007 08:49:05 GMT
On 6/28/07, Graham Dumpleton <graham.dumpleton@gmail.com> wrote:
>
> On 28/06/07, Mike <dykciarz@gmail.com> wrote:
> > Hello.
> >
> > When I'm trying to compile my example module on Mac OS I get following
> > error:
> >
> > ld: Undefined
> > symbols:
> >
> > _ap_filter_flush
> > _ap_hook_handler
> > _ap_pass_brigade
> > _ap_register_output_filter
> > _ap_rputs
> > _ap_set_content_type
> >
> > Those functions as you know are core Apache members and they reside in
> httpd
> > binary.
> > What's wrong? What should I do to compile the module. (Module compiles
> > without any error on Linux machine).
> How are you compiling the module, using 'apxs' or hand crafted
> makefile rules that invoke the compiler directly?


I need to use self-made Makefile since I'm writing module in C++.


Which Apache installation are you using? Default Apache 1.3 that comes
> with the operating system? Other binary Apache distribution for MacOS
> X or compiled from source code?


Compiled from the source code. ver. 2.2

Since ap_set_content_type() isn't in Apache 1.3, but is in Apache 2.X,
> almost looks like you are using the Apache 1.3 that comes with the
> operating system.
> I'm gonna try to clean up the instalation and try one more time.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message