httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Souramita Sen" <souramita_...@mindtree.com>
Subject RE: New to module development
Date Thu, 15 Mar 2007 05:43:28 GMT



While installing Fedora core I might have missed to install the following
rpms. 
So from rpmfimd.net i have installed httpd-devel, apr-devel and
apr-util-devel as mentioned by Joe and Drew. 

One small doubt. httpd version installed in my system is 2.2 and the latest
version of httpd-devel i got is also 2.2.
But latest version of apr-devel(2.0) and apr-util-devel(0.9) are not in sync
with corresponsing httpd version. Is there any compatibility issue here? Do I
need to have a older version of apache server installed for that reason?

And I did not get any links in google, what purpose do apr-devel and
apr-util-devel solve mainly? 

I could successfully create the module(apxs -g -n foo). But after all
required rpms are installed still I get the following error while compiling,
activating the module by apxs:

[root@localhost apachemodules]# apxs -c -i -a first
apxs:Error: /usr/bin/apr-1-config not found!.

(PS: either apr-devel or apr-util-devel installs apr-config not apr-1-config,
so the problem occurs) 

Regards,
Souramita.



-----Original Message-----
From: Drew Bertola [mailto:andrew@1100tech.com]
Sent: Thu 3/15/2007 2:56 AM
To: modules-dev@httpd.apache.org
Subject: Re: New to module development
 
Joe Lewis wrote:
> It should be provided with your distribution : apache-devel is the RPM 
> you need.

And probably apr-devel and apr-util-devel

--
Drew






DISCLAIMER:
This message (including attachment if any) is confidential and may be privileged. Before opening
attachments please check them for viruses and defects. MindTree Consulting Limited (MindTree)
will not be responsible for any viruses or defects or any forwarded attachments emanating
either from within MindTree or outside. If you have received this message by mistake please
notify the sender by return  e-mail and delete this message from your system. Any unauthorized
use or dissemination of this message in whole or in part is strictly prohibited.  Please note
that e-mails are susceptible to change and MindTree shall not be liable for any improper,
untimely or incomplete transmission.

Mime
View raw message