httpd-modules-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Wortham" <djwort...@gmail.com>
Subject Setting both Server and Directory Config Structs from the same config function
Date Thu, 16 Nov 2006 23:39:26 GMT
Hello fellow module developers!
I am trying to debug one of my directive-handling functions.

I want to set both the server and the appropriate directory structures when
the function is invoked.
Currently, I am getting Segmentation Faults (outside of all of my functions)
when I set my server configuration structure in my directive handling
function.  I never seem to get the same problem with my directory struct
(only the server struct), and I do check for NULL structs when I use them.
As you know, the Segmentation Faults occur when the webserver is started up
(halting startup).

I have commented out this specific directive and the Segmentation Fault
never occurs without this particular directive.  It seems to happen whether
I use the directive inside OR outside of a file/directory/location block in
the httpd.conf.

I believe the actual Seg Fault is occurring outside of my functions... I
have printfs to STDERR at the beginning and end of every function that
should run at startup. All of the functions that are opened close before the
Seg Fault error is shown.

Any ideas?  The line count on the code is pretty large so pasting everything
is pretty much out of the question.

Thanks,
Dave

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message