httpd-mbox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: mbox on 1.3?
Date Sun, 14 Oct 2001 19:34:29 GMT
On Sat, Oct 13, 2001 at 02:20:35PM -0400, Rodent of Unusual Size wrote:
> I take it mod_mbox doesn't work on Apache 1.3 at the
> moment, correct?  I'd rather like it to do so, but
> I'm not sure if that's a stated non-goal, or if it's
> so tightly bound to APR that it would be a futile
> undertaking..

I'd suggest your easiest alternative would be to run it on 2.0.  =)

The stated goal of mod_mbox (from Roy's and my perspective) was to
write a 2.0 httpd module that revolves around APR and apr-util.
I treated it as a mod_example (that was already taken!) that would
allow me to become more familiar with the httpd-2.0 codebase.  It
just happens to actually serve some alternative purpose.  =)

It may just be as simple as backporting mod_mbox.c to 1.3 module
semantics.  The rest of the files revolve around APR and APR-util.
It may be worth checking into the work that Pier has done for 
Tomcat 4.0's mod_webapp - it uses APR but has a 1.3 module 
component.  So, it is possible to use APRized modules with 
Apache 1.3.  -- justin


Mime
View raw message