httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Issue building the doc with openjdk 9
Date Tue, 24 Apr 2018 20:10:05 GMT
Am 24.04.2018 um 22:06 schrieb Rainer Jung:
> A result from a very partial test that I can't move on currently:
> 
> I tried Java 9 using a recent ant version and removing all the 
> XML/xslt/regep jar files that we have added long ago as well as the 
> bootstrap prepend option.
> 
> I didn't get the encoding problems but other errors. Search machines 
> indicated, that using saxon would help. Added saxon and the error 
> disappeared, but got another error about function use which seems to be 
> not supported by saxon.
> 
> So got stuck and ran out of time for this.

BTW: since Java 9 already got replaced by 10, investigations should 
probably continue using 10.

Not 100% sure about the current OpenJDK policy but it seems starting 
from Java 9 the project provides official binaries and those are in 
patch version sync with the ones from Oracle. So I think there will be 
no more free (as in beer) releases for 9. Of course vendoes like Red Hat 
can decide to provide builds on their own.

And btw: Java 10 will be replaced by 11 in September. Java 11 is the 
next LTS release.

Regards,

Rainer


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Mime
View raw message