httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rich Bowen <rbo...@rcbowen.com>
Subject Re: Aw: Re: Guide for Upgrade from 2.2 to 2.4: Need to mention default rule "<Directory /> Require all denied"
Date Tue, 05 Apr 2016 11:15:48 GMT
On Apr 4, 2016 10:19, "Hildegard Meier" <daku8938@gmx.de> wrote:
>
>
>
> <Location /server-status>
>         SetHandler server-status
>
>         Order deny,allow
>         Deny from all
>         Allow From 1.2.3.4
> </Location>
>
> _works_ with 2.4. Changing it to
>
> <Location /server-status>
>         SetHandler server-status
>
>         Require ip 1.2.3.4
> </Location>
>
> Gives
>
> "[access_compat:error] [client 1.2.3.4] AH01797: client denied by server
configuration: /var/www/docs/default/server-status"
>
> and does _not_ work anymore, so I have to switch back to old style.
>
>

You _must_ pick one or the other. Either use compat, or unload it. If you
have compat loaded, it expects the "old" format.

I thought we had made this clear in the doc but apparently not.

Recommended best practice, of course, is to use the new syntax. Compat
things always result in long term confusion in exchange for your short term
convenience.

Mime
View raw message