httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael.Schro...@telekurs.de
Subject Re: german translation of core.xml (2)
Date Mon, 13 Jan 2003 19:02:38 GMT

Hi Kess,


> The german translation of core is available at
> http://cvs.apache.org/~kess/mod/core.html.de.

are you able to incrementally update this file, so that
I won't post things that others already mentioned?


EnableSendfile-Direktive
========================
> Die Direktive steuert, ob httpd die sendfile-Unterstützung des Kernels
verwenden kann,
I would use "darf" instead of "kann" - this is about entitlement,
not about technical availability. (The English version uses "may".)

ErrorDocument-Direktive
=======================

> eine der vier Aktionen auszuführen:

I would prefer "eine der folgenden vier Aktionen auszuführen".


> Umleitung zu einem lokalen URL-Pfad der das Problem bzw. den Fehler
behandelt
One more comma after "Pfad", please.

> Anzeige im Browser angeboten werden. Beispiel:
Four examples are following, therefore: "Beispiele"
(plural, like in the English version)

>  ErrorDocument 403 "Der Zugriff ist nicht erlaubt."
-> ErrorDocument 403 "Der Zugriff ist heute nicht erlaubt."
(And yes, this _is_ pedantic. ;-)

> (d.h. irgendetwas mit der Methode http davor)
This may be another method as well, like "ftp://" - and the English
version did tell that. ("mit einer Methode wie z.B. 'http' davor")

>  auch wenn das Dokument letztlich wieder zum gleichen Server führt
rather: "Auch wenn dies letztlich wieder zu einem Dokument auf
dem Server führt." (It isn't the document's initiative here.)

> Die wichtigste ist, dass der Client nicht den Original-Statuscode
> erhält sondern statt dessen einen Umleitungs-Statuscode
I would insert a "davon" after "wichtigste", and one more comma
after "erhält".

> die den Statuscode dazu verwenden, herauszufinden ob eine URL gültig ist
And another comma after "herauszufinden".

> wenn sie "zu kurz" sind und ersetzt sie durch eigene
Again, a comma after "sind" would help.

> im Allgemeinen zeigt der MSIE jedoch den serverseitig generierten
> Fehler, anstatt ihn zu verstecken, wenn Ihr Fehlerdokument größer
> als 512 Bytes ist
I believe this order of the text parts to be misleading (where
does the "wenn" bind to?).
Swap these to: "zeigt der MSIE jedoch den serverseitigen Fehler,
wenn Ihr Fehlerdokument größer als 512 Bytes ist, anstatt ihn
zu verstecken".

> In Versionen vor 2.0 wurden Meldungen durch ein einzelnes
> vorangestelltes Anführungszeichen (") erkannt.

Of course this line is absolutely correct - but the previous
section was about the Internet Explorer.
Do we want to refer to this software's version 2.0 here? Surely
not. Just write "In Apache-Versionen vor 2.0" and I am happy.
(Applies to English version as well.)

ErrorLog-Direktive
==================
> wird er relativ zu ServerRoot betrachtet.
What about "ausgewertet" or "interpretiert"?
("assumed" would mean "angenommen" ... maybe a longer workaround
might be "wird angenommen, daß er ab ServerRoot ..." hm, und
jetzt fehlt mir wieder ein passendes Verb.)

> für jemand anderen, als den Benutzer, der den Server gestartet hat,
> beschreibbar ist.
I would try to escape this cascade of sub-sentences (which is
much more readable in English than in German) by rearranging
the parts: "gespeichert werden, beschreibbar ist für jemand
anderen als denjenigen, der den Server gestartet hat". (And no,
I wouldn't write a comma after "anderen" in your version.)

FileETag-Direktive
==================
> allows you to choose which of these -- if any -- should be used
About markup: Do you really want two minus signs here?
Maybe "—" could be closer to the desired effect.

> die von einem größeren Umfeld geerbt wurde
Hm ... I would love to have a better idea here.
(I would be less unhappy if there were a link to some place
explaining what a "Umfeld" is.)

> Wenn die Konfiguration für ein Verzeichnis FileETag INode MTime
> Size enthält
The last section of this directive looks to me as if it were
nothing but an example - it doesn't add new semantics. So why
not use the appropriate markup for it? (English version as well.)

<Files>-Direktive
=================
> Enthält Direktiven, die sich nur auf passende Dateinamen beziehen
I like your additional "nur" (only) here - maybe use it in the
English version as well?

> The <Files> directive provides for access control by filename
> ... It should be matched with a <Files> directive.
This combination of lines does not seem to make sense to me.
Maybe the second line should be "</Files>" instead of "<Files>",
i. e. a simple typo in the English version?

And if really so, then what might be the meaning of "should"
... is its use really optional?

And is it really a good idea to name "</Files>" a "directive"
(same with </Location>, by the way) but then explain it nowhere?
(To me, containers have always been a separate concept in the
Apache configuration, different from directives.)

The description for the <Location> directive (which is "termi-
nated" by </Location>) might be the better way to describe
things. (In German: "Sie muss durch eine zugehörige </Files>-
Angabe abgeschlossen werden" o. ä. - be aware that you translated
"should" to "muss"="must" here, which is not quite the same.)

Is "Container" your translation for "Section" (Abschnitt)?
(If "Container" were used in the English version, then I would
happily use it and not translate it to German ...)

> <FilesMatch> wird jedoch bevorzugt.
> <FilesMatch> is preferred, however.
By whom?
Maybe this should read "The use of <FilesMatch> should be
preferred" ... (and then somehow give a reason for this).

ForceType-Direktive
===================
> Erzwingt die Auslieferung aller passendenden Dateien mit dem
typo: passendenden => passenden
            ^^^^^^
> Sie können jede ForceType-Angabe durch die Verwendung des Wertes
> none überschreiben:
I would prefer "außer Kraft setzen", because "none" isn't
a literal value and doesn't "overwrite" a previous definition,
it rather disables it.

HostnameLookups-Direktive
=========================
> an CGIs/SSIs übergeben) werden könnnen
typo: könnnen => können.

> D.h. nachdem ein Reverse-Lookup durchgeführt wurde
I wouldn't start a new sentence with such an abbreviation
whose meaning is it to refer to a previous description.
In this case, I would write it out ("Dies bedeutet, daß ..."
and then swap the two partial sentences or combine them
with "and then" in chronological order).

> (In der "tcpwrappers"-Terminologie wird dies PARANOID  genannt.)
This looks like it might be worth adding a hyperlink to some
(external) document describing this terminology in more detail.

> egal ob das Doble-Reverse-Lookup fehlschlug oder nicht.
typo: "Doble" => "Double"

> um Netzwerktraffic bei den Angeboten einzusparen
besser: "... bei denjenigen Angeboten ..."

> sollten diese Direktive auf Offlassen
You sure want to insert a whitespace after "Off".



Sigh ... 40% only.
Looks like I will need about three more of these mails.


Regards, Michael



---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Mime
View raw message