httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Abele <>
Subject Re: german translation of core.xml
Date Sun, 12 Jan 2003 22:39:28 GMT
Astrid Keßler wrote:
>>As a general remark, I would prefer "Direktive X" to "X-Direktive"
>>in the directive headlines, but then this one would have to be
>>done consistently throughout the whole Apache translation.
> Yes, this would be a little bit nicer. I dicussed this with nd when I 
> requested an extension to the build process. (Previously all directive 
> headers result into "<directivename> Direktive" without the - sign.) Both 
> changes -- set "Direktive" in front of the direktivename or use a '-' sign 
> -- have been possible. I decided to use '-' only for one reason: When you 
> are scanning through the document, scrolling down, looking for a special 
> direktive (not using the sidebar), its easier to find the correspondig 
> directive, if its name is written in front of the header line.
> But this is just my personal opinion ...

I like the "X-Direktive" way, it's just easier to realize while scanning the doc. In "Direktive
X" the term "Direktive" seems to be much more redundant compared to the other way...

>>>Anm.d.Ü.:nicht gefunden
>>You might want to generate one additional whitespace after the ":"
>>in the XML-to-HTML build. 
> Yes, I've seen that. The xsl file did not what I expected. I'll have to 
> read some documentation. It couldn't be so difficult to create a space.

And please get also rid of the space before ")". This all seems pretty unbalanced :-)

>>>Der Core-Handler für gewöhnliche Dateien weist PATH_INFO standardmäßig
>>What is this supposed to mean?
>>I thought the directive as about rejecting requests, not about
>>rejecting the setting of the PATH_INFO value.
> The request line is not split into the requested resource and PATH_INFO but 
> taken as a whole to find the requested resource. This will result into a 
> 404 NOT FOUND. 

I think Michael just meant "...weist Zugriffe mittels PATH_INFO standardmäßig zurück" instead
of only "...weist PATH_INFO standardmäßig zurück", right? The 404 behaviour you intended
is absolutely right; just a too loose...

>>As a general remark, it may be a little bit confusing to write about
>>the ".htaccess files" when even this very name is configurable.
>>Isn't there some more abstract name for these?
> Using an abstract name could help to avoid lots of misunderstandings people 
> have with the name .htaccess.
> But ...this name is used all over in the documentation and people became 
> accustomed at it. A change would not only be a hugh effort but would also 
> confuse people. *hm hm*

This bugged me for years, but it seems there is no better way to name these files :-) A change
of the current docs would be immense I think, and what should they be called? Perhaps a 'decentralized
configuration file'? ehhh...urghh.

>>>Die AuthName übergebene Zeichenkette ist das, was in dem von den meisten
>>>Browsern angebotenen Passwort-Dialog angezeigt wird.
>>Do we actually know about browsers that don't provide a password
>>dialog but still support authentication?
>>On the other hand, I have seen a browser that will display the
>>dialog but not show the AuthName (Opera 3.5, fortunately very old
> Hm, maybe Lynx or other text based browsers?

Lynx shows the AuthName value when asking for username/password.

>>>nicht jedoch bei anderen Modulen
>>There is no equivalent to "andere" in the English version.
>>(Use "beliebige" to translate "any", or just omit it here.)
>>Using "andere" would mean that "core" is a module as well - is it?
> It's a poing of view. core is a module, yes, but it is also 'the core'. 
> Well in this context you are right, "andere" is not very helpful.

-1 to "andere".

>>><Directory Verzeichnis> ... </Directory>
>>I would use "Verzeichnispfad", as this one is about the name of
>>the directory, not about its actual content etc.
> I have difficulties to see why "Verzeichnis" could be understood as 
> "Verzeichnisinhalt". When I think of a directory, I'm thinking of its name 
> not its content.

I would prefer "Verzeichnispfad" too. Not because "Verzeichnis" could be misleading as Michael
stated, just because it is easier to understand. Why to complicate it when everybody knows
"Verzeichnispfad" and other terms _could_ be misleading?

And three other things:

  - "Beachten Sie jedoch, dass jedoch eine IP-Adressen die zu einer..."
    are the two "jedoch" intended?

  - "Zugangsinformationen"
    I would prefer just "Anweisungen" or better "Angaben"

  - "voll qualifizierter Pfad"
    I would propose "absolut". I knew about fully qualified domain names
    but I don't know any fully qualified paths, they are just absolute.
    Hmmm, but I see the englisch version isn't much better :-(
    Perhaps we should change this too? Thoughts?

  - (MaxKeepAliveRequests-Direktive)
    "Bei der Einstellung 0 sind unbegrent viele Anfragen erlaubt."
    -> unbegren_z_t

  - (NameVirtualHost-Direktive)
    "geben Sie die IP-Adresse an, an der der Server Anfragen"
    -> "..., auf der der Server..." ?

>>Uh, this is going to become really _long_.
> Hehe, yes, its one of the biggest or maybe the biggest document of the 
> whole documentation. It took me several days to translate. I have to thank 
> you for your review. The german translation will get really good with so 
> many review(er)s. 

Definitely. Thanks in advance for this great translation. The rest of the doc seems to be
very fine to me. It's really easy to read and understand.

I saw, that Michael got around the most other typos/'bugs', the above notes are just my 2c


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message