httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@apache.org>
Subject Re: Auth: Start the httpd-2.1 branch finally?
Date Sun, 13 Oct 2002 22:15:38 GMT
At 03:33 PM 10/13/2002, rbb@apache.org wrote:
>On Sun, 13 Oct 2002, William A. Rowe, Jr. wrote:
>
>> At 11:40 AM 10/13/2002, Jim Jagielski wrote:
>> >rbb@apache.org wrote:
>> >> 
>> >> In the message above, I don't
>> >> think you are advocating a 2.1 branch.  It sounds like you believe that
>> >> we should take the time to finish 2.0 before moving on.  Am I right in
>> >> interpreting it that way?
>> >> 
>> >
>> >+++1
>> 
>> Then I want to clarify ... you both object to the statement that developers
>> within HTTP should be free to work on what they want.  Obviously, you are
>> both stating that we should not introduce 2.1 anytime real soon now.
>> 
>> Therefore, you are stating that developers are not free to introduce radical
>> new code at the present moment, and only things that fit within Apache 2.0
>> [subject to perpetual debate over what exactly what fits within 2.0] are open
>> for community development efforts.
>
>Bill, I'm sorry, but you aren't reading the e-mails that have been
>sent.  You want to branch 2.1 so that people can make radical changes.  We
>are saying feel free to create patches with radical changes.  Once people
>can see the patches, we can decide if they belong in 2.1, 2.0, or if we
>don't want them in Apache at all.

You haven't read a single email on this thread.  The ENTIRE POINT of this
thread is that we have a radical change.  Auth.  Two Bills and who knows
whom all else may concur that we can't reasonably force this change 
into 2.0 for docs and upgrade reasons.

So we have a radical change.  I proposed we create 2.1 to incorporate auth.

>Please finally go back and read the messages where people have explained
>why they don't want to branch.  Also, as for the auth stuff, you seem to
>have completely ignored that Greg has offered a solution that might create
>backwards compat for the users with the new auth work.

Greg's post does not address the Docs issue.  I'm waiting for someone
to offer constructive feedback.  As I wrote in my response to Justin, I did
try to wrap my brain around documenting both pre and post auth in the
same /docs-2.0/ tree.  It didn't make any sense.  Perhaps someone else
can do better.

>You are so focused on getting a 2.1 branch, that you are ignoring any other 
>solutions to the problem that you have raised.

I'm focused on persuading the HTTP group to quit messing up administrators 
and third party module authors.  It matters very little to me if we make forward
progress if we continue to treat the httpd-2.0 tree as a sandbox and alienate
our third party authors and adopters.

Branch 2.1 now?  Only if we want to release the auth changes with all of
the upgrade issues of deprecating several released module.  It doesn't matter 
that "only the names have changed", this is called deprecating a module,
and it shouldn't happen within a GA release cycle on the same minor version.

Bill


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Mime
View raw message