httpd-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yoshiki Hayashi <yosh...@xemacs.org>
Subject Re: manual/style/build.xml
Date Mon, 29 Jul 2002 10:43:00 GMT
David Shane Holden <dpejesh@yahoo.com> writes:

> Looks like if we rename the files to file.xml-ja.jis and transform it, Xalan 
> will spit out the correct file extension and we wouldn't need to use 
> customized jars.

> > Looks like if we rename the files to file.xml-ja.jis and transform it, 
> 
> Correction.... file.xml-ja.jis should be file.xml-ja

Sorry, I'm -1 on this approach.  Naming files that way is
just working around the limitation of Ant.  I'd rather want
to enhance Ant or use other tool which can convert
file.xml.ja to file.html.ja.jis.  Also, Apache HTTP server
won't recognize xml-ja as Content-type: text/xml,
Content-language: ja.

> I just tried with the custom jars and I still get the same error.  I'm 
> wondering if it's an issue with Windows.  I actually get two different 
> errors when I validate and when I transform.  The validate error is

The cause of the error is the same.  Your Java runtime does
not understand iso-2022-jp encoding.  0x1b is ESC in
US-ASCII and it is the first byte of notorious iso 2022
escape sequence.  Sorry, I once saw this error in my
environment but I cannot remember how I fixed the problem.

I'm using this:
% java -version
java version "1.3.1"
Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.3.1-FCS)
Java HotSpot(TM) Client VM (build Blackdown-1.3.1-FCS, mixed mode)

> [xmlvalidate]
> manual/mod/mod_auth.xml.ja:8:15: An invalid XML character (Unicode: 0x1b) 
> was found in the element content of the document.
> 
> and the transformation error is
> 
> [style] Processing manual\mod\mod_auth.xml.ja to
>          manual\mod\mod_auth.xml.html.ja.jis
> [style] Loading stylesheet manual\style\manual.ja.xsl
> [style] Warning: encoding "iso-2022-jp" not supported, using UTF-8
> [style] : Fatal Error! org.xml.sax.SAXParseException:
>          The encoding "iso-2022-jp" is not supported.
>          Cause: org.xml.sax.SAXParseException:
>          The encoding "iso-2022-jp" is not supported.
> [style] Failed to process manual\mod\mod_auth.xml.ja

-- 
Yoshiki Hayashi

---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Mime
View raw message