httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <wr...@rowe-clan.net>
Subject Re: 2.4.x STATUS needs you!
Date Wed, 13 Dec 2017 12:07:55 GMT
I tend to agree that proxy, being a 'lower level' protocol, aught to
represent before remoteip presents itself. Overloading the module
seemed like a headache.

That said, as the author of remoteip, I consider my opinions highly
biased and untrusted by me myself, so you all sort that out :)

Thanks for the feedback,

Bill

On Wed, Dec 13, 2017 at 12:02 AM, Jordan Gigov <coladict@gmail.com> wrote:
> On 12 December 2017 at 11:32, Stefan Eissing <stefan.eissing@greenbytes.de>
> wrote:
>>
>> Fellow Apache developers: if we want to make an X-mas 2.4 release for the
>> people on this planet, the backports in STATUS need your attention:
>>
>> B2: mod_remoteip: Add PROXY protocol support
>>   - needs 1 more vote!
>>
> I find that trying to have both Proxy Protocol and the old remoteip
> functionality in the same mod is harder to maintain. I propose that they be
> split up before an official release.
>
> I have not kept-up with the changes over the past few months on the matter,
> but I do still have a patch for 2.4.29 that adds HTTPS-identifying headers
> to the original mod_remoteip, that also affect the choice of VirtualHost.

Mime
View raw message