httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Toscano <toscano.l...@gmail.com>
Subject Re: svn commit: r1802336 - /httpd/httpd/trunk/docs/manual/mod/mod_proxy_fcgi.xml
Date Wed, 19 Jul 2017 08:26:07 GMT
Hi Jim,

2017-07-18 23:00 GMT+02:00 <jim@apache.org>:

> Author: jim
> Date: Tue Jul 18 21:00:14 2017
> New Revision: 1802336
>
> URL: http://svn.apache.org/viewvc?rev=1802336&view=rev
> Log:
> UDS does support reuse
>
> Modified:
>     httpd/httpd/trunk/docs/manual/mod/mod_proxy_fcgi.xml
>
> Modified: httpd/httpd/trunk/docs/manual/mod/mod_proxy_fcgi.xml
> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/m
> od/mod_proxy_fcgi.xml?rev=1802336&r1=1802335&r2=1802336&view=diff
> ============================================================
> ==================
> --- httpd/httpd/trunk/docs/manual/mod/mod_proxy_fcgi.xml (original)
> +++ httpd/httpd/trunk/docs/manual/mod/mod_proxy_fcgi.xml Tue Jul 18
> 21:00:14 2017
> @@ -98,7 +98,6 @@ ProxyPassMatch "^/myapp/.*\.php(/.*)?$"
>      the hostname and optional port following fcgi:// are ignored.</p>
>      <example><title>PHP-FPM with UDS</title>
>      <highlight language="config">
> -# UDS does not currently support connection reuse
>  ProxyPassMatch "^/(.*\.php(/.*)?)$" "unix:/var/run/php5-fpm.sock|f
> cgi://localhost/var/www/"
>      </highlight>
>      </example>
>


Thanks for the clarification, I was trying to figure out why we had that
warning in the docs but didn't find anything useful. While chatting with
Daniel (ezra-s) on IRC it came up that some users reported on #httpd that
mod_proxy_fcgi errors out while re-using UDS sockets, but he didn't recall
the specific issue. In a recent dev@ thread this problem came up again, so
I did a little research and the best report that I found is the following:

http://z-issue.com/wp/apache-2-4-the-event-mpm-php-via-mod_p
roxy_fcgi-and-php-fpm-with-vhosts/#comment-6765

The user found the "UDS does not currently support connection reuse"
comment and solved the issue, so I am wondering if this was a
misconfiguration from his side or a known php-fpm limitation or a bug in
mod_proxy_fcgi. I haven't been able to reproduce and this might totally be
a false alarm, but if anybody has more info please speak up so we can
investigate it properly :)

Luca

Mime
View raw message