httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steffen <i...@apachelounge.com>
Subject Re: The drive for 2.4.26
Date Tue, 02 May 2017 06:17:46 GMT
Resume: With next 2.4 we have two not working with 1.1.  namely abs.exe with apr 1.6 and mod_session_crypto
with 1.5.

> Op 2 mei 2017 om 07:37 heeft William A Rowe Jr <wrowe@rowe-clan.net> het volgende
geschreven:
> 
>> On Mon, May 1, 2017 at 6:37 AM, Steffen <info@apachelounge.com> wrote:
>> No mod_session_crypto with apr & apr-util 1.5 and Openssl 1.1.0, error in
>> Apr:
>> 
>> Error    C2079    'cipherCtx' uses undefined struct 'evp_cipher_ctx_st'
>> apr_crypto_openssl
>> C:\VC15\Win32\httpd-2.4.26\srclib\apr-util\crypto\apr_crypto_openssl.c    67
>> 
>> With apr & apr-util 1.6 all fine.
> 
> Yes, this was covered in my earlier post, 2.4-branch+apr 1.5.x+OSSL 1.0.2
> is all fine.
> 
> 2.4.next+OSSL 1.1.x will require apr 1.6, with an appropriate disclaimer in
> the announce.
> 
> What was your question, again?


Mime
View raw message