httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregg Smith <...@gknw.net>
Subject Re: The drive for 2.4.26
Date Sat, 29 Apr 2017 16:16:16 GMT
APR 1.6 is needed for apr_crypto_openssl, obviously.

ABS: Not sure. When I originally tried building w/ APR 1.5 it didn't 
work, but it didn't work with OpenSSL 1.1 and APR 1.6 either. That has 
now been fixed by Rainer. Have not tried 1.5/1.1.0 w/ abs yet so I 
simply don't know. Feel free to try it. I have no time today to do it.

cvtdsp.pl assumes 1.6 is needed due to those first attempts and may be 
inaccurate. It's easy to just remove the xml.mak regex for 1.6 that's 
part of cvtdsp.pl -ossl11 (&toossl1), there is a separate -apr16 option 
for just the one change in APR (xml.mak's location). Maybe I should 
remove the part concerning APR 1.6 from the -ossl11 option.

Once APR 1.6 is released my plan is to make the change permanent next 
2.4.x then making the need for that conversion unneeded.

Openssl 1.0.2 is good till sometime in 2019, even 1.1.0 eol's before it 
does so we're stuck w/ cvtdsp.pl modifying the dsp files one way or 
another.

Anyone with commit access for apr can remove the part to modify for 1.6 
that is included in cvtdsp.pl -ossl110 (sub toossl1) if 1.6 really isn't 
needed for ABS.

Have a family member in the hospital who had surgery yesterday so this 
is my first time to even check mail since Wednesday morning. I have to 
go back to the hospital shortly.



On 4/28/2017 1:26 PM, Steffen wrote:
> I doubt now. It was based on a note in cvtdsp.pl.
>
> Maybe it is only a .dsp and xml change, which I can apply to 1.5.
>
> Maybe Gregg can shed some light on this ?
>
>
>> Op 28 apr. 2017 om 22:16 heeft William A Rowe Jr <wrowe@rowe-clan.net> het
volgende geschreven:
>>
>> Now that these are independent of one another, I think we can release before 1.6.x
are released. We should just call out "New: OpenSSL 1.1.0 support! (Upcoming APR 1.6.x is
required for this support.)
>>
>>
>>
>>> On Apr 28, 2017 2:56 PM, "Steffen" <info@apachelounge.com> wrote:
>>> When with apr & apr-until 1.6 fine even more cooler.  Otherwise OpenSSL 1.1
not supported.
>>>
>>> For OpenSSL 1.1 we need apr & apr-util 1.6 to build (e.g  apr_crypto_openssl
for mod_session crypto)
>>>
>>>
>>>> Op 28 apr. 2017 om 14:14 heeft Jim Jagielski <jim@jaguNET.com> het
volgende geschreven:
>>>>
>>>> It would be cool to have 2.4.26 released by ApacheCon, or even
>>>> by OSCON. There are, last I checked, 2 showstoppers on list for
>>>> 2.4.26... Anyway we could address them and shoot for a T&R maybe
>>>> next Weds?
>>>
>

Mime
View raw message