httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: svn commit: r1784990 - in /httpd/httpd/branches/2.4.x: ./ modules/lua/
Date Wed, 01 Mar 2017 17:44:46 GMT
Hmmm... WFM under macOS and fedora and centos.

> On Mar 1, 2017, at 12:21 PM, Jacob Champion <champion.p@gmail.com> wrote:
> 
> On 03/01/2017 08:54 AM, jim@apache.org wrote:
>> Author: jim
>> Date: Wed Mar  1 16:54:35 2017
>> New Revision: 1784990
>> 
>> URL: http://svn.apache.org/viewvc?rev=1784990&view=rev
>> Log:
>> Backport of Lua exhancements from trunk, mostly to support 5.3
> 
> In case it helps with the 5.3 effort: configure is not currently looking in the correct
"lua5.3" flavor of include directories. I have a set of two patches up [1, 2] but I haven't
checked them in yet because...
> 
>> Modified: httpd/httpd/branches/2.4.x/modules/lua/NWGNUmakefile
>> URL: http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/modules/lua/NWGNUmakefile?rev=1784990&r1=1784989&r2=1784990&view=diff
>> ==============================================================================
>> --- httpd/httpd/branches/2.4.x/modules/lua/NWGNUmakefile (original)
>> +++ httpd/httpd/branches/2.4.x/modules/lua/NWGNUmakefile Wed Mar  1 16:54:35 2017
>> @@ -46,6 +46,9 @@ XCFLAGS		+= \
>> #
>> XDEFINES	+= \
>> 			-DLUA_COMPAT_ALL \
>> +			-DLUA_COMPAT_5_2 \
>> +			-DLUA_COMPAT_5_1 \
>> +			-DLUA_COMPAT_MODULE \
>> 			$(EOLIST)
> 
> ...this doesn't help with compilation against Debian-distributed Lua 5.3, because they've
stopped enabling the deprecated compatibility APIs. I don't remember the exact APIs right
now, but I pinged Daniel about it a couple weeks ago, so he might. :D
> 
> --Jacob
> 
> [1] https://github.com/jchampio/httpd/commit/3d5e915f
> [2] https://github.com/jchampio/httpd/commit/eef76e90


Mime
View raw message