httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Champion <champio...@gmail.com>
Subject Re: Summary: Broken FastCGI with httpd
Date Mon, 30 Jan 2017 21:04:47 GMT
On 01/28/2017 07:22 AM, Jim Jagielski wrote:
> In your scenario does "old mode" == "old" Apache or non Apache?

"Old" Apache.

> My idea was to send FCGI data such that PHP-FPM doesn't use *any*
> Apache-related fixups. In other words, httpd sends "what it should"
> and PHP-FPM "uses what it receives"

Right. My point is that without simultaneous modifications to PHP-FPM, I 
see no way to do this without breaking deployed use cases, because of 
how easily the fixup code is triggered. And therefore IMO we shouldn't 
push that change in 2.4.26, but wait (for a reasonable amount of time) 
for both sides to agree on the way forward.

I'll try to review Eric's patch later this week, since it would help 
ease the migration pain (and give other users a path forward even with 
broken FCGI backends).

--Jacob

Mime
View raw message